Allow access to default document

Oct 17, 2012 at 6:53 PM
Edited Oct 18, 2012 at 6:42 PM

how do allow the default document to be allowed?

I have /SecureParameters/default.aspx as my defaultUrl and I have the following uriException

    <uriExceptions>
      <!-- Allow un-protected GET requests to test.aspx -->
      <uriException uri="/SecureParameters/" protectUri="false" protectQueryString="false" />
    </uriExceptions>

When I navigate to /SecureParameters/ I get a request forbidden page.

What am I doing wrong?

Coordinator
Oct 23, 2012 at 3:45 PM

Hi Brian, it’s been a while but try adding two exceptions (one with /SecureParameters/default.aspx and the other with just /SecureParameters/). Hope this helps.

From: bcbeatty [email removed]
Sent: Wednesday, October 17, 2012 2:54 PM
To: brian@gdssecurity.com
Subject: Allow access to default document [spf:399791]

From: bcbeatty

how do allow the default document to be allowed?

I have /SecureParameters/default.aspx as my defaultUrl and I have the following uriException

    <uriExceptions>
      <!-- Allow un-protected GET requests to test.aspx -->
      <uriException uri="/SecureParameters/" protectUri="false" protectQueryString="false" />
    </uriExceptions>
 
When I navigate to /SecureParameters/ I get a request forbidden page.

What Am I doing something wrong?




This message is private and confidential. If you have received this message in error, please notify us and remove it from your system.
Oct 23, 2012 at 4:03 PM
Edited Oct 23, 2012 at 4:04 PM

 

Thanks for the suggestion.

I added a file type exception, that appears to be working.
 <fileTypeExceptions>
        <add extension="/" protect="false"/>

but If I used "" instead of "/" it will turn off validation.